Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[HOW-TO] VPN working on your EQUISO [tun.ko module] Update Nov/18!
17-11-2012, 05:42 PM (This post was last modified: 18-11-2012 03:59 PM by Veronica.)
Post: #1
[HOW-TO] VPN working on your EQUISO [tun.ko module] Update Nov/18!
Today i decided to figure it out about how to get VPN working on the equiso and i did.

I suspected that EQUISO did not include the tun.ko module in their kernel natively so you must get a compatible tun.ko module for VPN to work.
I took a look at the tun.ko repository database and i saw that there was a tun.ko for the CX1 (similar/same hardware?)

Anyways here are the steps i followed to have a working VPN:

1. Download DroidVPN , Hotspot Shield VPN or the VPN app of your preference from the Google Play
2. Download TUN.ko Installer and CIFS Manager apps
3. Open tun.ko app, then tick Model: Smart TV (leave the other 2 ticked) and finally press INSTALL button.
You can also download the file tun.ko if you need it.
Once done you'll see the following:
[Image: shot_000023.png]


4. Open CIFS Manager, press menu button and select settings. Once there tick Load via insmod and modify the PATH as follows:
[Image: shot_000026.png]


If you go back to menu >> About.. >> Modules you will see all the Loaded Modules:
[Image: shot_000027.png]


After that you won't have issues with tun.ko module not loading and Hotspot Shield will work just fine.


5. Now open the VPN app that you downloaded (in this example i used Hotspot Shield), create an account if neccesary then START the VPN connection:
[Image: shot_000022.png]

6. DONE! you can now use Pandora or any other service that require an US IP address
[Image: shot_000025.png]

~ V

If i helped, please hit REP+ button / My XDA Profile ~ YouTube channel
Quote
10-02-2013, 11:50 AM
Post: #2
RE: [HOW-TO] VPN working on your EQUISO [tun.ko module] Update Nov/18!
Hello,

Thanks for the trick, but it's there a way to set it to be loaded on boot?
I don't understand why any time I reboot my equiso the tun.ko module disappears.

I also tried pushing it via adb. Same result..


Thanks in advance.
Quote
10-02-2013, 10:25 PM
Post: #3
Re: RE: [HOW-TO] VPN working on your EQUISO [tun.ko module] Update Nov/18!
(10-02-2013 11:50 AM)sukkia Wrote:  Hello,

Thanks for the trick, but it's there a way to set it to be loaded on boot?
I don't understand why any time I reboot my equiso the tun.ko module disappears.

I also tried pushing it via adb. Same result..


Thanks in advance.

Hello, that is why I added CIFS Manager steps. That app should load tun.ko in every boot.

Sent from my SGH-I897 using Tapatalk 2

If i helped, please hit REP+ button / My XDA Profile ~ YouTube channel
Quote
24-02-2013, 03:03 PM
Post: #4
RE: [HOW-TO] VPN working on your EQUISO [tun.ko module] Update Nov/18!
(10-02-2013 10:25 PM)Veronica Wrote:  
(10-02-2013 11:50 AM)sukkia Wrote:  Hello,

Thanks for the trick, but it's there a way to set it to be loaded on boot?
I don't understand why any time I reboot my equiso the tun.ko module disappears.

I also tried pushing it via adb. Same result..


Thanks in advance.

Hello, that is why I added CIFS Manager steps. That app should load tun.ko in every boot.

Sent from my SGH-I897 using Tapatalk 2
Done, but it doesn't work for me.
Quote
24-02-2013, 06:48 PM
Post: #5
Re: RE: [HOW-TO] VPN working on your EQUISO [tun.ko module] Update Nov/18!
(24-02-2013 03:03 PM)sukkia Wrote:  
(10-02-2013 10:25 PM)Veronica Wrote:  
(10-02-2013 11:50 AM)sukkia Wrote:  Hello,

Thanks for the trick, but it's there a way to set it to be loaded on boot?
I don't understand why any time I reboot my equiso the tun.ko module disappears.

I also tried pushing it via adb. Same result..


Thanks in advance.

Hello, that is why I added CIFS Manager steps. That app should load tun.ko in every boot.

Sent from my SGH-I897 using Tapatalk 2
Done, but it doesn't work for me.

Do you have the standard model?

Sent from my SGH-I897 using Tapatalk 2

If i helped, please hit REP+ button / My XDA Profile ~ YouTube channel
Quote


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | Equiso Smart TV Forum | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication