Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MX player won't stream over the WLAN
09-02-2013, 03:42 AM
Post: #1
MX player won't stream over the WLAN
Hi I installed ES File explorer and MX player and the idea was to share directory on my PC and to stream on equiso over wireless. But it doesn't work. When I start the movie there is no picture and no sound but the progress bar moves like it is actually playing something. BUT if I copy that movie through ES File explorer locally to equiso stick and then play it in MX player than it plays and everything is ok.

What could be the reason for this? Permissions on my PC directory are obviously ok because if they weren't I wouldn't be able to copy file to equiso stick. Everything is obviously ok with MX Player / codecs because it plays well when file is directly on equiso stick... Wireless signal is also full...

HELP! I bought this only to be able to stream from my PC and not to copy/paste to my usb stick and carry it from PC to tv over and over again...

bezkintos, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Oct 2012.
Quote
09-02-2013, 10:49 AM
Post: #2
RE: MX player won't stream over the WLAN
@bezkintos:
I don't have my PRO yet, but some thoughts:

- did you install the appropriate codec for MX Player?

- use a tool like Network Monitor Mini or Network Speed to show if/when the data is streaming into the Equiso stick - should show peaks of 2 Mb/s or more.

- try another player like BS Player Free.

Good luck!

Jeff Schallenberg
Mont Saint Hilaire, Québec
Quote
09-02-2013, 02:38 PM (This post was last modified: 09-02-2013 02:39 PM by bezkintos.)
Post: #3
RE: MX player won't stream over the WLAN
Thank you Jeff, I appreciate your help very much!

I tried everything you have said, but no luck.

1. I don't think it is caused by codecs because when I copy/pase movie locally in equiso stick it plays well. Also there is a notice aboute MX player codecs on google play: "** IMPORTANT NOTICE: This is a software component for MX Player, you
should install MX Player first. MX Player will test your device and show
you the best matching codec automatically if it is necessary. You do
not need to install codecs unless MX Player asks."

2. I installed Network Monitor Mini and it shows speeds about 3-9 Mb/s when copy/paste from my PC shared folder to equiso stick, but when I start to stream directly then this high speed is up only for about 1 second, and then drops to few Kb/s. During this I have no picture and no sound but the progress bar in MX player moves like it is actually showing something and I can see the correct duration of that "invisible and silent movie"

3. I tried with BS player but strange... it freezes as soon as I start it up. A few times it stayed unfrozen for a few seconds and during that time I had only sound but no picture...



I have to mention that I use this combination of ES File explorer and MX player on my smartphone and it works great, so I guess this is to blame to equiso stick not the apps?

bezkintos, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Oct 2012.
Quote
09-02-2013, 04:15 PM
Post: #4
RE: MX player won't stream over the WLAN
(09-02-2013 02:38 PM)bezkintos Wrote:  2. I installed Network Monitor Mini and it shows speeds about 3-9 Mb/s when copy/paste from my PC shared folder to equiso stick, but when I start to stream directly then this high speed is up only for about 1 second, and then drops to few Kb/s. During this I have no picture and no sound but the progress bar in MX player moves like it is actually showing something and I can see the correct duration of that "invisible and silent movie"
So, there is no problem with WiFi - ES is transferring the file from the PC to the stick at full speed. But Equiso is not streaming at all. First time I ever heard of that problem, and I don't know what to suggest. I use ES to stream all the time on my Android tablet and my Android TV box.

Jeff Schallenberg
Mont Saint Hilaire, Québec
Quote
09-02-2013, 06:41 PM (This post was last modified: 09-02-2013 06:50 PM by bezkintos.)
Post: #5
RE: MX player won't stream over the WLAN
Hi Jeff.

I'm dealing with this for hours trying to figure it out. And I finally did it! Main reset helped and now equiso can stream from shared directory in an earlier described way.

I don't know why and what's going on with that but I saw here on forum several topics where nothing helped and than the user decided to do a main reset and everything worked fine after that. And I'm talking about stuff not working from the moment it got out of the box, not after days, weeks or months of using it.

I suggest to everyone to do the main reset first thing as soon as they plug equiso for the first time!

Thanks again Jeff for your help on this subject!

And another thing. Some of the movies I tried out are ok, but some of them shows a slight lag. Not only while streaming but also when playing them directly from equiso stick. The same thing is on my smartphone so I guess MX Player is responsible for that... I'm still investigating what are the differences between those files that plays well and those with small lag...

bezkintos, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Oct 2012.
Quote
09-02-2013, 08:17 PM
Post: #6
RE: MX player won't stream over the WLAN
@bezkintos:

1) What do you mean by "main reset helped"? AFAIK, the Android Settings menu only includes a "Factory data reset" option - is that what you are referring to?

2) After doing a reset, can you stream your .mkv videos from your PC to your Equiso? Any stuttering?

3) You say that some files play with a "lag". You are not the only user to use that word, and I wonder if you are talking about stutter (where the video repeatedly freezes for a moment before starting again) or if you mean there is delay or loss of synchronization between the video and the sound?

Jeff Schallenberg
Mont Saint Hilaire, Québec
Quote
10-02-2013, 01:32 AM (This post was last modified: 10-02-2013 01:54 AM by bezkintos.)
Post: #7
RE: MX player won't stream over the WLAN
1.Yes, you are right, not main reset but factory reset like the one some guy have done here as a solution for his Internet speed issue (the only difference was that I also checked the box: 'Erase internal storage'). So I did it as my last option (although, my speed was ok) for my issue i.e. not be able to stream from my PC, and it worked.

3. Yes stutter is probably a better word. I'm not native english speaker so I probably caught not enough precise meaning of the term lag. As you said, video repeatedly freezes for a fraction of a second before starting again and that goes in circle. When you watch it, it is almost unnoticeable... but still little annoying. I found solution for that. Some of those stuttering video, when watched in MX PLayer, are played pretty well in VLC Player: 'VLC for Android Beta' (Also tried 'VLC Direct Pro Free' but there was stutter on .avi while streaming and playing locally). So I won't think twice about that... 'VLC for Android Beta' is for now my number one. But I also kept MX Player and you'll see why in answer to your second question:

2. First I tried to stream .mkv from my PC usuing 'VLC for Android Beta' but VLC crashes immediately although .avi (xvid) streams well. Then I tried to stream .mkv using MX Player and it took it WHOLE 5 minutes to stops loading (that circle orbiting was all that time on the screen) and starts to play, but, surprisingly once it started to play it played well. I also tried to copy/paste .mkv locally to equiso stick and again the same story with VLC (both versions) but MX Player started playing video after only few seconds and played well.

So I must use MX Player for .mkv files, and VLC for movies which stutter when watched by MX Player... I'll Try to remember all this... Big Grin

bezkintos, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Oct 2012.
Quote
10-02-2013, 12:46 PM (This post was last modified: 10-02-2013 12:47 PM by Barthwo.)
Post: #8
RE: MX player won't stream over the WLAN
Full HD Videos do not play at all or at an extremely low frame rate on the Equiso Pro with MX Player and VLC. I have tested with mp4 (directly from my Samsung Galaxy S2), H264 (ts-container from HD TV in Germany), webm (vp8 codec with videos from the Internet for example YouTube HD). Same with streaming locally at highest WiFi speed with access point directly beneath the Equiso Pro.

Barthwo, whose Equiso Pro finally arrived.
Quote


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | Equiso Smart TV Forum | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication