Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Pro Experiance
08-01-2013, 04:09 AM
Post: #1
The Pro Experiance
I just wanted to start a new thread so we can talk about the experience with the Pro's. I received 1 of 2 I backed today. So far it runs well except the store freezes a lot. After playing with it I am thinking maybe it is the Airplay app that is freezing Android.

Also the Pro doesn't work with my IOGEAR HDMI switch enough though the standard did. It works fine to my 2006 Regza Toshiba TV

Anyone else receive theirs?

MobileWill, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Jan 2013.
Quote
08-01-2013, 04:19 AM (This post was last modified: 08-01-2013 04:21 AM by blackk.)
Post: #2
RE: The Pro Experiance
Has some picture of the real device? How many USB outputs?
Thanks in advance.
Quote
08-01-2013, 04:31 AM
Post: #3
Re: The Pro Experiance
It has one USB port on the side with the microUSB charge port and SD slot on the rear. It also has vents.

Here is a quick picture. The box is also about twice as big as the standard.

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2


Attached File(s) Thumbnail(s)
   

MobileWill, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Jan 2013.
Quote
08-01-2013, 04:37 AM
Post: #4
RE: The Pro Experiance
Overall my Pro experience has been half-assed.

For starters, it will not work on 3 out of 4 HDTVs in my house. A Toshiba, Sony Wega, and Panasonic HDTV all will not recognize the device. also tried a HP monitor with HDMI input that would cycle to it saying it was "Active" then to "No Signal".

However, after already shooting off an email to support saying my device was defective, I finally tried our main room Sony Bravia, and it finally worked! Unbelievable that it won't work on any of other major name-brand HDTVs.

Downside, is that the Wifi in the main-room only has a 5GHz N extender, and the 2.4Ghz signal doesn't penetrate the room well so my Equiso constantly drops the Wifi connection.

I'm wanting to know though if we can use the BETA firmware here...
http://www.equisoforum.com/Thread-Beta-s...h-november

..on our Pro units? It says they fixed the black screen on many TVs in the changelog, however, the build date on the Pro unit is 20121213 which is newer than that one, so I'm not sure if it'll work.


However, I've barely used the thing and can't access the Play Store and everytime I get my wifi connected I get a pop-up saying something has force closed.

At this point I've wanted to just benchmark the stupid thing but I can't even get into the Play Store. Frustrating...
Quote
08-01-2013, 04:38 AM (This post was last modified: 08-01-2013 04:40 AM by MobileWill.)
Post: #5
Re: The Pro Experiance
Here is a better picture.


Sent from my SAMSUNG-SGH-I747 using Tapatalk 2

I was able to watch YouTube no problem. I want to test airplay later tonight. I hope an update will fix it working with the hdmi switch.

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2


Attached File(s) Thumbnail(s)
   

MobileWill, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Jan 2013.
Quote
08-01-2013, 04:54 AM
Post: #6
RE: The Pro Experiance
For me the Pro Experience was sketchy at first.. It all started with signing into Google. It wouldn't authenticate correctly. But then I had a popup with new updates.. So I go to update youtube (only app installed oob) and had error 921. The only way to fix that, from what I found, was to remove the account and sign in again. Welp that means a factory reset.. Undecided This went on 3 times.. But on the 4 try I was able to sign in to google, had the error, but was able to update youtube.

Next step, Netflix! I install netflix, open click around, start a video and plays like a dream Exclamation Surely 10 times better than any of the 4 standard units I backed!

I've installed and watched videos on Netflix and crackle so far and have yet to have a hiccup.. (wait knock on wood! Big Grin ) I've had to do the family thing shortly after ward but in the time that I had played with the Pro and after I got past the google playstore, it's snappy and has 0 lag.

Here is a few pics from opening the box. (digging the new stick style too!)


   


   


   


   


   
Quote
08-01-2013, 06:03 AM (This post was last modified: 08-01-2013 06:04 AM by dzap.)
Post: #7
RE: The Pro Experiance
PROGRESS! Big Grin

I was able to get it to work with my Sony Wega after removing a screw (it was just above my HDMI port) that apparently was blocking the Equiso from going in all the way.

This HDTV is right next to the router so I was finally able to get to the Play Store and root the device.

Just benchmarked. Not bad overall.
   


Going to try NetFlix, hulu+, and XBMC now. Wish me luck! Shy
Quote
08-01-2013, 06:11 AM
Post: #8
RE: The Pro Experiance
Congrats to those who have received so far. I haven't got any email yet.

I am very curious to know their surprise feature? What is it?

Gopichand Pai, proud to be a member of Equiso Forum - Discussion Forums for the Equiso Smart TV since Nov 2012.
Quote
08-01-2013, 06:19 AM (This post was last modified: 08-01-2013 06:22 AM by blackk.)
Post: #9
RE: The Pro Experiance
Based other devices, possible the specifications:

CPU: Nufront NS115 Cortex-A9 Dual Core 1.2GHz
GPU: Mali 400
RAM: 1GB DDR3
Storage: 4GB NAND Flash
Wifi: 802.11 b/g/n
Ports: 1x USB Host port + 1x microUSB DC port + 1x microSD (Up to 32 GB)
Video Output: HDMI 1.4a 3D (Up to 1080p)
OS: Android 4.1.0 Jelly Bean (ICS appearance)
Quote
08-01-2013, 06:44 AM (This post was last modified: 08-01-2013 06:45 AM by dzap.)
Post: #10
RE: The Pro Experiance
(08-01-2013 06:11 AM)gopichandpai Wrote:  Congrats to those who have received so far. I haven't got any email yet.

I am very curious to know their surprise feature? What is it?
Looks like Wi-Fi Direct (option is under "More...") and Bluetooth made the cut. Big Grin

Very happy with the bonus features. Smile

(08-01-2013 06:19 AM)blackk Wrote:  Based other devices, possible the specifications:

OS: Android 4.1.0 Jelly Bean (ICS appearance)
Everything else is correct except this. It is NOT running Jellybean (I have a Nexus 7 and Nexus 4, so I definitely know, that this is not just an "ICS skin").

It is running ICS 4.0.3.
Quote


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | Equiso Smart TV Forum | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication