Equiso Forum - Discussion Forums for the Equiso Smart TV

Full Version: External sd card Not reading all of the sudden
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Help!! I bought a 32 gb microsd hc and a san disk reader/writer 3 weeks ago... I popped the SD card into Equiso stick and it found it came formatted NTSF... everything was fine.. Unfortunately, I had to wait until the internal is full before it would use my external or I just couldn't find out how to switch it... So it is been inside but nothing had been saved to it... I did a dumb thing thinking there is nothing on there anyways and took it out of the Equiso without unmounting it !! I connected it to my windows 7 86x laptop and transferred two files over from the laptop, told the laptop to safely eject it ( it said it had)... Then placed it back into the Equiso and nothing... after rebooting 3 times nothing... it will not read it at all like it's not in the port at all... I tried clicking on mount external but it's greyed out it will not let me ... I've also taken the sd card out a few times while the equiso is off and reinserted it.. Is there anything I can do???

Does your computer still recognize the sdcard?
Nope it dawned on me after I posted this to check and it won't show up on the computer now either, I've tried different ports and plugged it in 5 times... nada...like it doesn't exist nothing at all ... So I am guessing it died??? At this point i just want to know if it was something i did so it could be prevented (maybe I write protected the card by accident when I told it to safe eject?) or if it was just bound to happen because it's a generic card and or a defective generic card
Reference URL's