Equiso Forum - Discussion Forums for the Equiso Smart TV

Full Version: KimDecent T21 Firmware
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have this morning had a bit of a screw around with my Equiso Pro, seeing as I really don't care much if it works anymore or not.

I searched for other Android sticks using the NS115 chipset and tried to find closest spec to Equiso as I could. Ended up finding the Kimdecent T21 DroidStick, for which I have downloaded the firmware and flashed to the Equiso (after a little bit o minor fiddling).

The firmware boots, seems stable but definitely lacks some vital features such as WIFI/Ethernet support, I am thinking that this is where the Equiso specifications (hardware components) differ to the Kimdecent.

I think that in all honesty, if there are some people here who might know where to start in terms of adding the missing functionality to the Kimdecent firmware, that this might be the way for us to go about getting a decent firmware for our devices.

I would really like to hear thoughts from someone who knows what they are doing with this though.....
Which KimDecent rom did you try and what flash method did you use? Or did you just rename the the zip to update.zip and let the built-in flasher do its job?
No that one is actually an APK for an app that you can use to control the T21 with your android phone.

The one I installed was this one:

http://www.kimdecent.com/drivers/127.html


I have managed to copy a 2.7GB 720P video file and BSPlayer APK to a USB, and the video file runs flawlessly in Video Player (default Google app) but picture does not show in BSPlayer.

As for getting the firmware onto the Equiso, I did the following:

1. Downloaded the Kimdecent firmware.
2. Extracted the files to a folder.
3. N.B. Kimdecent has their own application for creating a SD card used to flash the device. This application is called NS115-Burn.exe. Note that it is not compatible with Windows 7 (or 8 I assume) so I ran in XP Compatibility mode and it worked.
4. Use NS115-Burn.exe to create a Micro SD Boot Card.
5. Insert the Micro SD into Equiso (with power cord unplugged).
6. Hold down the previously useless button on the Equiso, then insert the power cord.
7. Continue holding until you see something on the screen and wait until the whole thing says Install Complete.
8. It did not auto reboot after completing so I had to unplug power physically.
Interesting.... Can you update us on that.
Would be great if the remote app from the T21 could be ported to the Equiso

Telegraphed from my i9300
LIFESAVER!!!

I did that update that was rolled out for the Equiso, and it effectively broke anything that actually worked on it, but I installed this, and I'm back and working, sort of.

For some reason, I can't get WiFi to turn on. It kinda freezes the settings menu.
There's no Bluetooth. I noticed it said it couldn't find it when installing it.

I'll update this post if anything weird happens. I know it's bound to happen, since this wasn't specifically written for this stick.

What is the significance of holding the button? I reset the stick, forgetting to take out the stick, and it just installed all over again without the button being pressed.

Update: Below is what I get upon install.

BT not found
Not NW53, delete FmRadio

But why would the WiFi not work?
I updated yesterday. No issues so far. Its working great for me. No errors. But I haven't tested the antutu score yet.

Sent from my Galaxy Nexus using Tapatalk 2
So your WiFi works then?
Yes everything is working on new equiso pro update.

Sent from my Galaxy Nexus using Tapatalk 2
(17-03-2013 01:01 AM)Niko Wrote: [ -> ]Yes everything is working on new equiso pro update.

Sent from my Galaxy Nexus using Tapatalk 2
The KimDecent T21 Firmware, right?

If so, I can't seem to get wifi to work on it. It just hangs when I go to turn wifi on. No error message or anything.
Pages: 1 2
Reference URL's