Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Replacement parts
Last Post: Zodiac69
27-09-2015 09:48 AM
» Replies: 2
» Views: 2871
Where did Equiso Go?
Last Post: SoulDaemon
30-10-2014 10:47 PM
» Replies: 2
» Views: 1866
Fix for Google Play Movie...
Last Post: browser supported
24-10-2014 05:02 PM
» Replies: 25
» Views: 19867
Equiso Pro Stock ROM --Fl...
Last Post: svartalf
30-07-2014 09:21 PM
» Replies: 22
» Views: 12689
Any Type of Recovery Avai...
Last Post: svartalf
30-07-2014 09:15 PM
» Replies: 13
» Views: 7548
internet speed
Last Post: annmaria
07-07-2014 01:24 PM
» Replies: 5
» Views: 2141
Equiso Play new game cons...
Last Post: gedi223
05-05-2014 07:29 PM
» Replies: 14
» Views: 5841
Need some help here
Last Post: svartalf
04-05-2014 07:15 PM
» Replies: 1
» Views: 4015
Pro: CPU Governor & enabl...
Last Post: svartalf
03-05-2014 04:18 AM
» Replies: 1
» Views: 9528
Equiso Pro Linux Kernel S...
Last Post: svartalf
03-05-2014 04:07 AM
» Replies: 9
» Views: 7908

 
  Replacement parts
Posted by: Zodiac69 - 04-04-2015 07:56 AM - Replies (2)

Does any one know where i can get a replacement remote fob?
I lost mine....don't ask

Print this item Send this item to a friend

  Where did Equiso Go?
Posted by: SoulDaemon - 27-10-2014 03:51 PM - Replies (2)

The support site is gone, the website is down. Where did Equiso go? Are they out of business?

I sent my Equiso in for the retail version exchange program and I did not receive a new Retail Equiso and it looks like they've dropped off the face of the earth.

Anyone know what happened?

Print this item Send this item to a friend

  internet speed
Posted by: gmish - 20-05-2014 03:20 AM - Replies (5)

Why is it that when I do a speed test on my android galaxy 3 I get a download speed of about 35 mbs.... but when I do the same speed test on my android equiso stick I get a download speed of about 8 mbs? It's the same app, one run on my droid phone and the other on your equiso stick.... both the same distance from the router, but your device gets only 25% of the internet speed. How come?

Print this item Send this item to a friend

  External sd card Not reading all of the sudden
Posted by: barrios1213 - 29-04-2014 04:04 AM - Replies (2)

Help!! I bought a 32 gb microsd hc and a san disk reader/writer 3 weeks ago... I popped the SD card into Equiso stick and it found it came formatted NTSF... everything was fine.. Unfortunately, I had to wait until the internal is full before it would use my external or I just couldn't find out how to switch it... So it is been inside but nothing had been saved to it... I did a dumb thing thinking there is nothing on there anyways and took it out of the Equiso without unmounting it !! I connected it to my windows 7 86x laptop and transferred two files over from the laptop, told the laptop to safely eject it ( it said it had)... Then placed it back into the Equiso and nothing... after rebooting 3 times nothing... it will not read it at all like it's not in the port at all... I tried clicking on mount external but it's greyed out it will not let me ... I've also taken the sd card out a few times while the equiso is off and reinserted it.. Is there anything I can do???

Print this item Send this item to a friend

  Firmware update
Posted by: anton77 - 05-04-2014 07:52 AM - No Replies

My Equiso Smart TV Pro version 20130709. Android v.4.0.3.
How can I update firmware, after reboot nothing happened.

Print this item Send this item to a friend

  New opportunity for refunds or exchange?
Posted by: pointfr - 03-04-2014 01:08 PM - Replies (2)

Hi!

If you haven't already done so, checkout the comments section for the Equiso Play.

Of interest:

Quote:CreatorEquiso 7 days ago
@Julian We're sorry about your experience with our previous product and we'd be happy to send you the latest version at no cost to you. Send us an email at hello@equiso.com.
and
Quote:Creator Equiso on Mar 27
@Michael So sorry to hear about the your Smart TV Stick. Have you sent a follow up email since? We are committed to making sure you get what you need - especially with Equiso Play. Send us an email at hello@equiso.com and we'll do our best to get you a new device as soon as we can.
Even Adams father is weighing in on the action:
Quote:Kenneth McBride 4 days ago
Michael, it sounds like you are pretty bitter and distraught over last Equiso investmen. I understand that it didn't work out for you. I could not tell on your comment page what your actual problem was (you spoke about two different things). Please give me your address and I would be happy to pledge a cash refund for you first Equiso investment. Adam is a good guy and I hate to see some one with such a small investment terrorize him. You can see his family has great respect and confidence in him and we know personally this project is real and will be all it is said to be. With a full cash refund you will be made whole and should have no reason to speak ill anymore. He has a family and feelings just like you do. My email
is kensmcbride@gmail.com
Phil

Print this item Send this item to a friend

  Equiso Play new game console?
Posted by: blkcamarozr28 - 26-03-2014 05:44 AM - Replies (14)

Just got this in email. Hopefully their open source is better then what we got on the standard, pro, walmart retail version. Dodgy

Hey,

I hope you're having an awesome day. Eight years ago, we had a vision and started it on SourceForge: an open source gaming console. It’s finally ready. 

Equiso Play brings you AAA games such as Call of Duty and Need for Speed at an affordable price ($99). We’ve crammed in a ton of features to bring great performance and the ability to play the latest games in 1080p. Equiso Play allows you to mirror your Android or iOS smartphone, tablet and Apple desktop so you can use your TV as a second – larger – screen for apps, games and movies with Netflix, Hulu and so much more. As a bonus, we provide you all the source code and drivers to install Linux and custom ROMs, making Equiso Play a truly open source console.
 
Rewind real quick to June 2012 when 2,703 of you made our Android-powered Equiso SmartTV Stick a success. We loved working with you to create and deliver a retail consumer product. Supporting an early stage Kickstarter project can be a bumpy ride and we thank you for being patient, daring and part of our vision. We learned a lot about what works and what we needed to do better. Thanks to you, we now have the chance to bring another idea to life.
 
We’d love for you to be a part of the next gaming revolution. To do this, we need your help getting Equiso Play from the drawing board into your hands.

As we anticipate the go-ahead from Kickstarter, we have each and every one of you in mind. To show our depth of gratitude, we have exactly 2,703 early bird specials just for you.
 
As soon we hit that big green ‘live’ button, we’ll send you the link.
 
In the meantime, we’d love to hear from you. Questions? Curiosities? Excitement? Zip it over to us: hello@equiso.com.
 
From the bottom of our gaming guru hearts, please join us on this journey and thank you, thank you, thank you.

Print this item Send this item to a friend

  Xfinity - expired credentials
Posted by: Colchester - 05-03-2014 06:32 PM - No Replies

Does anyone else keep getting kicked off the Xfinity player app. I keep getting "error msg 3001 login credentials expired, please login again." Anyone know of a fix for this. Comes on every 10-15 min or so. I've already tried clearing the cache, reinstalling the app, logging out of all other devices. nothing seems to work.

Print this item Send this item to a friend

  Equiso won't boot - Kickstarter Standard
Posted by: RunnenLAte - 27-12-2013 09:51 AM - Replies (2)

Hello Everyone,

I'm new here but have had an Equiso since the kickstarter. Recently I tried to update my Equiso via USB but afterward it would not boot up all the way. It will power on and display the Equiso logo but will not get past that. No loading circle, nothing. just hangs there for hours. Now I've searched and searched online but can not find anything on how to fix this for the standard edition. I've found stuff for the pro version with an SD card but mine does not have an SD card expansion slot so I can not load a recovery image onto the device. I tried loading it onto a USB drive to see if it would pick that up but nothing. I installed the adb drivers and was able to get the device to be recognized by my computer but was unable to get much done like that as I didn't think I could manually push anything to the device. even when I tried I get the error error exec system/bin/sh failed no such file or directory(2). I contacted support but have not heard anything back from them yet. Does anybody have any idea what I can do or try to get this thing to boot again. Thanks

Print this item Send this item to a friend

  Boot/Activity Light ?
Posted by: MinstrelMike - 08-12-2013 12:11 AM - Replies (3)

Hi guys! Pardon a non-Equiso-owner (yet) for posing a question?
I spotted one of these Equisos in a local "discount" store, at 80% off; that's down to about $15-16 +tax, almost low enough for me to take a shot that it might not work at all, but not quite.

I unpacked it at the store's "test" table, finally noted the red light on the remote when plugged into the charger (hard to see depending on angle and ambient light).

However: when plugging in the Equiso itself to the charger (via. micro-USB), I didn't notice any lights at all; I found a single mention on the web site about a blue light which flashes while booting, but is normally off (after boot completed).

Here's my question(s):

1) Must the Equiso be plugged into an actual HDMI device (TV etc) in order to boot and/or activate/blink a visible indicator light ? (works "headless"?)

2) WHERE exactly IS the blinking boot light?

I watched several youtube videos, but only one barely showed a SOLID blue light, which seemed to be there even after it finished booting ?! This light appeared to be top left corner w/usb port to left (but video was too dark to tell WHICH side was facing) ...

3) I suppose I should just ask: Are there any other "useful" ways to "verify" this device "cold" with OUT any "HDMI" output (nor wi-fi sniffer, etc.), just to know (or have some indication) that it even "works" at all ? (no matter what the "discount" it's not worth ANY thing if it doesn't even work - stuff is too small for parts scavenging, included cables/remote not worth that much to me).

I appreciate any replies; if I find out any thing that seems "useful" I might go back on Monday and see if it's still there. The only other information that I thought to note was the UPC "8 57308 00400 7" (if that's any help, version-wise, etc. - available on Amazon.com & Walmart.com - only in stores, but not online ?!) ...

Thanks!

Print this item Send this item to a friend


Contact Us | Equiso Smart TV Forum | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication